centos 用yum安装软件、升级出现File /usrbinyum”,line29,inyummain.user_main(sys.argv[1:], exit_code=True)…错误

最近在折腾centOS7的时候用yum update命令想升级一下软件包,没想到出现了一大堆莫名其妙的提示,如图

用yum install 安装软件包也不行,同样的提示。没办法,百度呗。

看了一些方法,最终选择了更改yum配置文件的方法。

用vim编辑 /etc/yum.conf文件

把plugins = 0 改为 = 1,然后退出保存。最后再输入yum update

问题解决